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Prefacio

Este foi um trabalho desenvolvido pelos Alunos Luiz Ardo Aradjo Carvalho e Aéccio
Cardoso Queiroz, na Disciplina de Sistemas Distribuidos com professor Paulo Canedo, vendo a
quantidade de passos a ser seguido para a criacdo e teste de um Web Service resolvemos criar
um mini tutorial com todos os passos mostrados pelo professor em sala de aula. No inicio era
apenas um arquivo texto bem simples, o que as vezes dificultava a visualizacdo de alguns
processos importantes, entdao resolvemos criar um Tutorial mais completo com imagens e mais
detalhado, erros de portugués vao ser facilmente encontrados, por isso era para consumo
préprio e ndo importava o real significado das palavras e sim se nds a entendiamos.

Agradecemos por estar lendo esse prefacio chato, por que se fosse eu ndo estaria
lendo isso ndo. Esse Material é totalmente livre podendo ser copiado, modificado e distribuido
livremente pedimos apenas que mantenham as referencias dos autores originais.

Sugestoes, Criticas ou agradecimento podem ser enviados para qualquer um dos
emails:

maximusmano@gmail.com

asuquiroz@yahoo.com.br

Boa leitura e boa sorte, vocé vai precisar.

Algumas coisas que pode ser Uteis:
- Nomes que podem variar de acordo com sua aplicacdo estdo em Azul .
- nome de alguns botdes referenciados em nosso tutorial possuem um Realce Cinza
- Este Tutorial foi feito Utilizando as seguintes ferramentas
> Servidor GlassFish v2
> Versao do java EE 5
> NetBeans 6.1


mailto:maximusmano@gmail.com
mailto:asuquiroz@yahoo.com.br

Projeto:
File -> New Project-> Web -> Web Application

Choose Project

Categaries: Projects:

..... ) Java (= 'i=h Application
..... I wehb () wWeb Application with Existing Sources

..... L3 Enterprise s Web Free-Form Project
----- ) Ruby

----- I3) MetBeans Modules
#-IC0) samples

Descripkion:

NEXT >
Nome de sua Aplicagao: MyWebService
NEXT >

2) Escolha o Servidor, no nosso caso GassFish V2. Depois a versao do Java EE, deixe 5.
Server and Settings

Add to Enkerprise Application:

SErvEr: | GlassFish vz

Use dedicated library Folder For server JAR Files

Jawva EE Version: | JavaEES »

Contexk Path: |,|'M§.-"-.-'-.-'el:uService

FINISH > (ja podemos finalizar nosso projeto.)

Pronto nosso projeto WebService estd pronto, vamos ao Servidor

Criar Servidor:

File -> New File -> Web Services -> Web Service




Projeck: |I@ MywebService

Cakegories: File Types:
----- [T JavaServer Faces =R/ eh Service
..... ) Skruks ‘Web Service from WSOL
_____ £ Spring Framewark @; RESTFul Wweb Services from Entity Classes
_____ £ Java £S5 RESTFul web Service Client Stubs
. @; RESTFul Web Serwvices From Patterns
----- ) JavaBeans Objects ) )
) Q Web Service Client
""" 5 Junit Secure Token Service (STS)
""" ) Persistence Logical Handler
----- =) web Services Message Handler
..... [ﬁ ML
----- T3y GlassFish
----- T Other s
NEXT >

Web Service Mame; |I"-’I§.r"-.-'-.-'553rvid|:|r

Project: |I"-'1§.f'-.-'-.-'e|:uServi|:e

Location: |5|:u_|r|:e Packages

Package: |'-.-'-.-'5F‘kg

(*) Create \Web Service from Scratch

() Create Web Service Fram Existing Session Bean

Enterprise Bean:

Coloque o nome do seu Web Service[MyWsServidor] e coloque o nome do pacote(Package)

| Browse, ..

[ wspkg](OS: ndo use como na imagem, use apenas letras minusculas) o resto deixe como esta.

FINISH ]

OK, Nosso Servidor de Web Service Esta Pronto. Vamos rodar o Servidor



Iniciar Servidor:

Na Aba SERVICES (Ou CTRL+5) V4 a SERVERS -> GlassFish, clique com o Direito e em START

:Projects :Files ’Eﬁer?ices i =
% Databases
.@. Weh Services
@; Erkerprise Beans (2,x)
EI Servers
(f ilassFish 2
-l werick (Ul
Start in Debug Mode
Start in Profile Mode

Refresh
Remove

Yiew Admin Console
Yiew Server Log

YWiews Update Center

:MyWsServidor.java - ] 1 =
Properties
Web Service Design W

I_"i Timar abimne

Adicionar Operacao:

Clique no Botdo Add Operation
MyWsServidorService

Operations [ Add Operation... | |




Ird aparecer a janela abaixo, Vamos criar um simples Somador de niumeros. Entdo Vamos |a.
Em Name Coloque o nome da sua Operacdo(metodo), no nosso caso soma em Retun Type o
valor que a Operacdo ira retornar [int](Java.lang.Integer), logo abaixo os parametros que
devem ser passados(x:int e y:int). pronto, aperto OK.

Mame: |su:|ma |

eturn Type: |java.lang.Integer | | Erowse... |
Parameters | Exceptions
Marne Type Final aad

Fy ink ]

Remove

) e

Up

Deve Ficar Assim:

Operations | Add Operation... | | |
(=) soma ENEERES
Parameters Output Faults Description
Farameter Mame Parameter Type
X int
v int

Editando a Operacao :

Vamos Agora dizer o que nosso método deve fazer:

Temos dois modos de edi¢do: Source(Cddigo) e Design(Interface). Para alterarmos de
modo utilize os dois botdes referentes a ele[Source] e [Design](Mostrados na figura abaixo),
ou as teclas de atalho [Ctrl+Alt+page Down] ou [Ctrl+Alt+page Up]. E encontre o metodo
SOMA.



Start Page xl@index.jsp x]MyWsServidDr.java x]

EIEE e~

MWsSerddorService

Source

Operations | Add O

Ou ainda mais fécil e agil na janela Navigator(Navegacdo) [CTRL+7] dé um duplo clique em
soma.

- 50ma - Mavigator il =

Members Wiew L
=Ry MyWsServidor

Sl W somalint x, ink ) @ Integer

g 0065, =

Vocé ira ser Direcionado para este método:

@webMethod(operationName = "soma')
public Integer soma(@webParam(name = "x")
int x, @webParam(name = "y")
int y) {

return null;

Bom a Unica coisa que queremos é somar o valor de x e y e
retorna-los, entdo:

@GwebMmethod(operationName = "soma')
public Integer soma(@webParam(name = "x")
int x, @webParam(name = "y")
int y) {

return x+y,;

Bom com nossa Operagdo pronta vamos ver como esta.




Iniciando e testando o Web Service:

Com a aba Project(Projetos) selecionada(Ctrl+1), clicamos com o direito no projeto e
em UnDeploy and Deploy (Desimplantar e Implantar ) nosso projeto.

:Pr...

E@ webpa e L

DD WEE gy

] inde Cle:an and Build
-3 Web Se
@ Configu
>@ Server |
@ Source |
@ TestPai Run
@ EY=  Undeploy and Deploy
@ Testlib  Debug

‘MyWsServidor - | Profile

40 = -Files

-Favorites | Services F
~ -

Clean
Werify
Generate Javadoc

Members Wiew
S MyWsServic
e () somalin

2et as Main Project

Close

Rename...

Mrwe

Agora é SO Executar apertando na seta verde no topo da aplicacdao(Ou Simplesmente
F6):

Refactor EBuild Run  Profile  Yersioning Tools  Window

E®D¢ §Wg b -G

% i Services Ska = @ index.jsp x] [y
1| source | Design b - | K

ll."ﬁﬁ
*

* gauthor Ehao=

Se tudo Ocorreu certo Seu Navegador ird abrir automaticamente com a Mensagem
“HELLO WORLD”, no endereco http://localhost:8080/MyWebService/



Testando a Operacao no Web Service:

Bom, mas cadé minha soma?? Calma, isso era somente para testar o nosso Servidor,
vamos agora testar nossa operag¢ao implementada:

Bom entdo vamos |3, volte ao NetBeans e para a Aba de projetos(Projects), va até a
pasta Web Services clique com o Direito em Seu Arquivo Servidor [MyWsServidor] e va ate
Test Web Service.

Pr... 41 = l;Files :Favorites | :Services Skart Page
E@ MyWebService Source |_D
[+ I03 Wweb Pages N
E}I@ Web Services MyWs:

[@ Configuration Files  Open

>IE Server Resources Refresh Service
IE Source Packages
IE Test Packages
i@ Libraries Test Web Service
I@ Tesk Libraries

Aadd Operation. .

Edit ‘Web Service Attributes

:s0oma - Mavigator Configure Handlers., .,

Members Yiew

Generake and Copy WSOL. .,
- MyWsServidor

i) sormalink =, int ) Delete Delete
Properties
1 Opl
7 Rel

As vezes aparece essa mensagem mas o navegador abre, entdo ignorem :P

¥ Information |E|

i
Could not access the URL through the external browser. Check the browser configuration.




Opa. Agora sim, Nossa Operacao esta ai, vamos testa-la. Vamos colocar 2, 3 e Apertar em
Soma.

Arquivo Editar  Ewibir Hiskdrico  Faworitos  Eerramentas  Ajuda

oy e
- - ikth._’J |_d_1: L http:fflocalhost:3030/MyWwebservice My s Servidor Service T Tesker

’ Guia rapido 5y Clkimas noticias

| | J5P Page | | MyWsServidorService Web Servi... [LJ

MyWsServidorService Web Service Tester

Thiz form will allow you to test vour web service unplementation (W SDL File)
To mwvoke an operation, fll the method parameter(s) mput boxes and chck on the button labeled wit
Methods :

public abstract java lang Integer wspkg My Waberndor. somalint, mt)

( : )

E Estd ai nosso Resultado. 2+3 retorna um Interio “5”.

soma Method invocation

Method parameter(s)

Tvpe | Value

it 2
it 3
MhMethod retiuned

java.lang Integer ; "S"




Distribuindo seu Web Service:

Voltando a Pagina Anterior temos na primeira linha depois do titulo:

“This form will allow you to test your web service implementation (WSDL File)”
Nesse WSDL File Esta o Link de Distribuicdo, o Cliente que ird consumir seu Web Service deve
utiliza-lo. Cliqgue com o direito e copiar link(no FireFox).

Arquivo Editar  Ewibir Hiskdrico  Faworitos  Eerramentas  Ajuda
_ il g
- S |_d_1: L http:fflocalhost:3030/MyWwebservice My s Servidor Service T Tesker
’ Guia rapido 5y Clkimas noticias

| | J5P Page | | MyWsServidorService Web Servi... [LJ

MyWsServidorService Web Service Tester

Thiz form will allow you to test vour web service unplementation CWSDL File)
To mwvoke an operation, fll the method parameter(s) mput boxes and chck on the button labeled wit

Methods :

public abstract java lang Integer wepkg MyWsserndor somafint int)

(soms ) ¢ , )

Consumindo Web Service:

Agora Vamos criar o cliente que ira utilizar o seu Web Service para fazer suas somas (XD).

File-> New File -> Web Service -> Web Service Client



http://localhost:8080/MyWebService/MyWsServidorService?WSDL
http://localhost:8080/MyWebService/MyWsServidorService?WSDL

Project: | () MywebService e

Categories: File Types:
-7 Web . Weh Service
-I7) JavaServer Faces i Web Service From WSOL
53 Struts @; REATful Weh 3ervices from Entity Classes
&) spring Framework &Y RESTFuUl Web Service Client Stubs
pFIng .
&Y RESTFUl Web Services from Patterns
10 Java [CWieh Service Client
I JavaBeans Objects Secure Token Service (STS)
<) Junit Logical Handler
-|2) Persistence Message Handler
-|J) Web Services
h WML o
|7 GlassFish "
NEXT >

Aqui vocé deve Selecionar a Op¢dao WSDL URL e colar a Url que vocé pegou |a do WSDL File no
seu Servidor, em nosso caso:
http://localhost:8080/MyWebService/MyWsServidorService ?WSDL

WSDL and Client Location

Specify the wWsDL file of the Web Service,

() Project: | | Browse. ..

) Local File: | | Browse..,

o) weSDL URL: ||:I:,I',I'|Dl:a|hl35t:BDBD,I'M':.-'".l'l.l'EbSEr\-‘iEE,I'M‘:.-‘WSSErVidDrSEFViEE?WSDL| [ Set Prooy. .. ]

Specify a location For the client.

Projeck: |M':.-"-.-'-.-'EI:|Servin:e |
Package:
Client Style: | JAR-WS Style v

[ ] =enerate Dispatch code

FINISH ]


http://localhost:8080/MyWebService/MyWsServidorService?WSDL
http://localhost:8080/MyWebService/MyWsServidorService?WSDL

Apos Criar o Cliente vamos criar o Servlet

File -> New File -> Web -> Servlet

Choose File Type

Project: |@ FywebService e
Categories: File Types:

----- T3 wweb ~| |& sp -~

----- [ Javaserver Faces 5]

----- [ﬁ Skruks é_ﬁl Filter

_____ C3 Spring Framewaork r_‘_;c?] Web Application Liskener

----- =f s

""" ) JavaBeans Objects 11'1;1 Cascading Style Sheet

""" I Junit (28] JawaScript File

----- [0 Persistence 2] ISON File

----- [ wweb Services 5| Tag Handler L3

..... T3 =ML — | |#%% TagLibrary Descripkor

----- [y GlassFish w % Tag '_:"E »

NEXT >

Dé um nome ao seu Servlet [MyWsServlet] e Escolha o pacote que ira conte-la[wspkg] finalize

Mame and Location

Class Mame: |M3-"-.-'-.-'sSer'v'Iet |

Project: |M':.-'Wel:uSer'-.-'i|:e |

Lacation: | Source Pack:

Package: |

Created File: |D:'|,r'-'1an|:| DiocumenkosiMetBeansProjecks\MywiebServicel srcljavaiMyWwisServlet . jawa |

FINISH >

Agora Vamos colocar nossa operac¢do no Servlet.

Destro do cdédigo do arquivo: MyWsServlet, Procure pelo Metodo “protected void
processRequest” e descomente o Codigo que estd dentro dele, ou adicione outro cédigo HTML
dentro da fungao out.Printin.

protected wvoid processReguest (HoCpl3ervletRegquest reguest, Ht
throws SerwvletException, IOEXception
response.setContentType ("text/ htmlcharset=UTF-2") ;
PrintWriter out = response.getWriter () :
try i

out.println("<html=>"}:

out.princln("<head:>")

out.println("<title>Zervlet MylWzsfervlet</titlex™);
out.println(”</head:="):

out.println("<hody>T);

out.println("<hl>Servliet MylsServlet at " + request.
out.println("</body="):

out.println(™</homl="");



Apods Feito isso clique com o direito logo abaixo do cddigo va ate a opcao:

Web Service Client Resources->CaI_I Web Service Operation

try |
out S
Mavigate
ot
Show lavadoc
ot

out  Find Usages
ouY  Refactor

ouUt  Formak

out  Fiy Imports

U Ingert Code...

Run "MyWsServlet, java"
v Final  Debug "MywsServiet java”

ot
H Mew Watch. .,

Toaggle Line Breakpoint

5 I Profiling
¥ x |:Tasl

® || Retriever Qukp
rwice:

Paste
Code Faolds
Select in
Document o=y M
rands)

Enterprise Resources

Web Service Client Resources

]
Alk+F1 _
rrvlets/titlex")
alk+F7
]
AE+Shift+F 2T &t " 4+ regquest.getc
Ckrl+3hift+1
Alt+Insert
Shift+Fa
Ckel+35hift+FS
Crel+35hift+F7
Crel+FE
]
:HTTP Monitor
widorService, wsimpart-client-compile;
Chel+y
]
]

ebWWEE-INFclass=ses

W Select Operation to Invoke

Available Web Services:

EI@ My\WebService
B MysServidorService
Elﬁ MyWsServidorService
=-BE MywsServidarPart

- 's)

E Aperte -




Nesse momento um cddigo ird aparecer baixo de seu HTML, agora vocé ira coloca-lo
entre as tags <body> </body> . assim:

out.praintin( </ heads>") ;
C out.printlni“<body=");

try { // Call Weh ZService OQperation

int = = 0;

} cateh (Exception ex)

H
C out.println(</ lbody=");
out.println(™</html="]:

V finally {

out.println("<hl=3ervlet HMylisServlet st

" + request.getConte:

wspky. MyWslervidor port = service.getMylWsSerwvidorPort () :
F4 TOoDD initialize WS operation arguments here

int v = 0;

ff TODO process result here

jawva. lang. Integer result = port.sowalx, ¥l:
out.println("Fe=zult = " 4+ result);

f4 TODD handle custom exceptions here

Seu Codigo estd pronto para Execugdo Tecle -, ird aparecer uma mensagem
requerendo o Servlet Execution URI, pressione- .
!

W Set Servlet Execution URI [z|

i
=
H
i

Select servlet execution URI, optionally add some request parameters :
e.q. /Alowerserviet?flower=rosefcolor=red

|,|'M':.stServIet

v)

You can change the execution URI laker via Toaols = Sek Servlet Execution URI,

(o] 4 ][ Zance




